From AbiWiki

Jump to: navigation, search


FAQ: Postscript Output Problems


I am finding that all postscript output (to printer or file) is mangled since AbiWord 1.0.4 and including 2.0. Since everyone seems happy with AbiWord, I assume I am doing something to make my postscript output bad.

All my postscript output comes out with some spaces converted to backspaces randomly!! The result is that words are run together and sometimes even overlap. Weird. I did a google search, and found that somebody posted this to the Debian (I am using Slackware) folks as a bug, but there was no detectable followup.

Somebody did mention that rtf support was *not* broken, and that exporting rtf and printing that from [[OpenOffice|OpenOffice]] worked!!

What happened to the postscript output after 1.0.3 and why is it only affecting (apparently) a small number of users?


_From a post by Dom Lachowicz on 25 Sept 2003:_

This behavior *could* be caused by our use of a "characterWidths" array. We dont translate spaces into backspaces (postscript has no concept of a backspace, anyway). We translate them into moveto() operations, which just happen to move PSs pen "backwards" on the page. I dont know why this is going wrong for you. It works fine here and everywhere else Ive tried. Does it happen for just some particular fonts?

Apparently this is not a known bug — if you are interested in getting it fixed you should add it to bugzilla, and you may wish to join the abiword-users@abisource.com mailing list.


Personal tools